summaryrefslogtreecommitdiffstats
path: root/booster/src/Makefile.am
diff options
context:
space:
mode:
authorShehjar Tikoo <shehjart@gluster.com>2009-05-20 22:50:10 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-05-20 22:47:17 -0700
commitef7fcc0d7c2695ab3b10477b3e1290e43831da99 (patch)
treee5f7d4e4ed0e2255e14c02a1b78fa123655ea08f /booster/src/Makefile.am
parent5bb6653c434c74b5f2d5b706f60f8d4149a40a2d (diff)
booster: Move fstab parsing into booster from libglusterfs
This is another attempt at fixing build problems on Solaris. I am told that booster build is disabled on Solaris and I know that it is disabled on Mac OS X also. Getting it to work on both these systems is now on my TODO list, mainly because on both these systems, we can have a glusterfs client running without requiring FUSE. Signed-off-by: Anand V. Avati <avati@dev.gluster.com>
Diffstat (limited to 'booster/src/Makefile.am')
-rw-r--r--booster/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/booster/src/Makefile.am b/booster/src/Makefile.am
index 1b3be737..50aaa668 100644
--- a/booster/src/Makefile.am
+++ b/booster/src/Makefile.am
@@ -2,7 +2,7 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
ldpreload_PROGRAMS = glusterfs-booster.so
ldpreloaddir = $(libdir)/glusterfs/
-glusterfs_booster_so_SOURCES = booster.c booster_stat.c
+glusterfs_booster_so_SOURCES = booster.c booster_stat.c booster_fstab.c
glusterfs_booster_so_CFLAGS = -I$(top_srcdir)/libglusterfsclient/src/ -D_GNU_SOURCE -D$(GF_HOST_OS) -fPIC -Wall \
-pthread $(GF_BOOSTER_CFLAGS)
glusterfs_booster_so_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE \