summaryrefslogtreecommitdiffstats
path: root/api/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-02 13:37:08 -0400
committerAnand Avati <avati@redhat.com>2012-10-02 13:11:43 -0700
commit04371377f2f1a842ee3875f9fa415bbc97f20f65 (patch)
tree8c133e19e50e110c4825bd2e37249bdd915aded1 /api/src/Makefile.am
parentc1d129fec4e8810e0080a276d29ec49fe4cfc4fb (diff)
build: remove -nostartfiles flag
The "-nostartfiles" is a discouraged option and is documented to potentially result in undesired behavior. Since I see no reason why it should be in glusterfs, remove it. Change-Id: I56f2b08874516ebad91447b2583ca2fb776bb7ab BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4018 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'api/src/Makefile.am')
-rw-r--r--api/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/api/src/Makefile.am b/api/src/Makefile.am
index e59c8583..d96c87db 100644
--- a/api/src/Makefile.am
+++ b/api/src/Makefile.am
@@ -13,7 +13,7 @@ libgfapi_la_CPPFLAGS = $(GF_CPPFLAGS) -D__USE_FILE_OFFSET64 $(GF_CFLAGS) \
-I$(top_srcdir)/libglusterfs/src \
-I$(top_srcdir)/rpc/rpc-lib/src \
-I$(top_srcdir)/rpc/xdr/src
-libgfapi_la_LDFLAGS = -shared -nostartfiles
+libgfapi_la_LDFLAGS = -shared
xlator_LTLIBRARIES = api.la