summaryrefslogtreecommitdiffstats
path: root/auth/login/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'auth/login/src/Makefile.am')
-rw-r--r--auth/login/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/auth/login/src/Makefile.am b/auth/login/src/Makefile.am
new file mode 100644
index 000000000..eb7b990c2
--- /dev/null
+++ b/auth/login/src/Makefile.am
@@ -0,0 +1,13 @@
+auth_LTLIBRARIES = login.la
+authdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/auth
+
+login_la_LDFLAGS = -module -avoidversion
+
+login_la_SOURCES = login.c
+login_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =