summaryrefslogtreecommitdiffstats
path: root/xlators/mount/fuse/src/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@gluster.com>2011-05-20 16:56:27 +0000
committerAnand Avati <avati@gluster.com>2011-05-30 04:48:44 -0700
commit80b84f4b852c2794c46af4de1e8ab48673163dc3 (patch)
tree993e13940106c7ed45236fd3f49403f74f7104b5 /xlators/mount/fuse/src/Makefile.am
parentbeb2b28ff105bad260c4fda891c174a6bff0abd4 (diff)
fuse: NetBSD portability fixes
- NetBSD uses libperfuse(3). - Add @GF_FUSE_LDADD@ to fuse.so library dependecies so that -lperfuse is added at configure time for NetBSD. Thanks to: Emmanuel Dreyfus <manu@netbsd.org> Signed-off-by: Anand Avati <avati@gluster.com> BUG: 2923 (NetBSD port) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=2923
Diffstat (limited to 'xlators/mount/fuse/src/Makefile.am')
-rw-r--r--xlators/mount/fuse/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/xlators/mount/fuse/src/Makefile.am b/xlators/mount/fuse/src/Makefile.am
index 3dace143a..7bb3931ec 100644
--- a/xlators/mount/fuse/src/Makefile.am
+++ b/xlators/mount/fuse/src/Makefile.am
@@ -16,6 +16,7 @@ fuse_la_SOURCES = fuse-helpers.c fuse-resolve.c fuse-bridge.c \
$(CONTRIBDIR)/fuse-lib/misc.c $(mount_source)
fuse_la_LDFLAGS = -module -avoidversion -shared -nostartfiles
+fuse_la_LIBADD = @GF_FUSE_LDADD@
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS) -Wall \
-I$(top_srcdir)/libglusterfs/src -I$(CONTRIBDIR)/fuse-include \