summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/Makefile.am
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2012-09-24 09:50:44 +0200
committerAnand Avati <avati@redhat.com>2012-09-26 11:17:02 -0700
commitbc2b5977a52baff96ffd69b118967a82d5933555 (patch)
tree4dae5cbe6851e9f41f31f7249dd3e605a5f1fca4 /libglusterfs/src/Makefile.am
parent36db38a5722127e9f330915783cddae453be5db3 (diff)
Fix parallel build issues
Prevent creating symbolic links in not yet created sbindir. Since lex creates two files, make them depend on each other to prevent race condition. Change-Id: I72b633b24de33407006d70571b0a40adaa99dc2b BUG: 859843 Signed-off-by: Kacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com> Reviewed-on: http://review.gluster.org/3968 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'libglusterfs/src/Makefile.am')
-rw-r--r--libglusterfs/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libglusterfs/src/Makefile.am b/libglusterfs/src/Makefile.am
index 0921a2901..5edba293c 100644
--- a/libglusterfs/src/Makefile.am
+++ b/libglusterfs/src/Makefile.am
@@ -46,6 +46,7 @@ EXTRA_DIST = graph.l graph.y
graph.lex.c: graph.l y.tab.h
$(LEX) -t $(srcdir)/graph.l > $@
+y.tab.c: y.tab.h
y.tab.h: graph.y
$(YACC) -d $(srcdir)/graph.y