summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-03 09:30:27 -0400
committerAnand Avati <avati@redhat.com>2012-10-03 12:24:59 -0700
commit1ecbb7ca68bd39ede792414b21a772469ecb4094 (patch)
treeb54d1e8b7c54e6f9a03cf7ef0452c61582ba81d5 /libglusterfs/src/Makefile.am
parentec79583cfd2ae10998dedfeb0c2c2a83a81cdec3 (diff)
build: remove useless explicit -fPIC -shared from
CFLAGS libtool will automatically add "-fPIC" to the compiler command line as needed, so there is no need to specify it separately. "-shared" is normally a linker flag and has an odd effect when used with libtool --mode=compile, namely that it inhibits production of static objects. For that however, using AC_DISABLE_STATIC is a lot simpler. Change-Id: Ic4cba0fad18ffd985cf07f8d6951a976ae59a48f BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4027 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'libglusterfs/src/Makefile.am')
-rw-r--r--libglusterfs/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libglusterfs/src/Makefile.am b/libglusterfs/src/Makefile.am
index 4c7adea7f..6b55c6452 100644
--- a/libglusterfs/src/Makefile.am
+++ b/libglusterfs/src/Makefile.am
@@ -1,4 +1,4 @@
-libglusterfs_la_CFLAGS = -fPIC -Wall -shared $(GF_CFLAGS) \
+libglusterfs_la_CFLAGS = -Wall $(GF_CFLAGS) \
$(GF_DARWIN_LIBGLUSTERFS_CFLAGS)
libglusterfs_la_CPPFLAGS = $(GF_CPPFLAGS) -D__USE_FILE_OFFSET64 \