summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuis Pabon <lpabon@redhat.com>2014-03-28 15:41:31 -0400
committerLuis Pabon <lpabon@redhat.com>2014-03-28 15:41:31 -0400
commit9ca7aba27a96c61371da08325856d88ac9783db1 (patch)
tree9631a84a0ac6d37890f18128c1273641fdc66231 /configure.ac
parentefbb23837761bda6c526baca1b5ea72d227e2ae3 (diff)
build: NSR requirement on curl
* Added a libcurl requirement to the configure script * Fixed the Makefile to use the built libgfapi version, not an installed one. * Tested recon.t and it worked. Change-Id: Ie2fc07da33e4bdb8a8aa911ac8225b82025775a7 Signed-off-by: Luis Pabon <lpabon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a365a53..d1302ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,7 @@ fi
AC_CHECK_TOOL([LD],[ld])
AC_CHECK_LIB([crypto], [MD5], , AC_MSG_ERROR([OpenSSL crypto library is required to build glusterfs]))
+AC_CHECK_LIB([curl], curl_version, ,AC_MSG_ERROR([libcurl library is required to build glusterfs]))
AC_CHECK_LIB([pthread], [pthread_mutex_init], , AC_MSG_ERROR([Posix threads library is required to build glusterfs]))