summaryrefslogtreecommitdiffstats
path: root/xlators/meta/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/meta/src/Makefile.am')
-rw-r--r--xlators/meta/src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/xlators/meta/src/Makefile.am b/xlators/meta/src/Makefile.am
new file mode 100644
index 000000000..385ff553f
--- /dev/null
+++ b/xlators/meta/src/Makefile.am
@@ -0,0 +1,10 @@
+xlator_PROGRAMS = meta.so
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/
+
+meta_so_SOURCES = meta.c tree.c misc.c view.c
+noinst_HEADERS = meta.h tree.h misc.h view.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles
+
+CLEANFILES =