summaryrefslogtreecommitdiffstats
path: root/xlators/features/marker/utils/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/marker/utils/src/Makefile.am')
-rw-r--r--xlators/features/marker/utils/src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/xlators/features/marker/utils/src/Makefile.am b/xlators/features/marker/utils/src/Makefile.am
new file mode 100644
index 000000000..74e2b3ef5
--- /dev/null
+++ b/xlators/features/marker/utils/src/Makefile.am
@@ -0,0 +1,20 @@
+gsyncddir = $(libexecdir)/glusterfs
+
+gsyncd_PROGRAMS = gsyncd
+
+gsyncd_SOURCES = gsyncd.c
+
+gsyncd_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+gsyncd_LDFLAGS = $(GF_LDFLAGS) $(GF_GLUSTERFS_LDFLAGS)
+
+AM_CFLAGS = -fPIC -Wall -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src\
+ -DGSYNCD_PREFIX=\"$(libexecdir)/glusterfs\"\
+ -DSBIN_DIR=\"$(sbindir)\" -DPYTHON=\"$(PYTHON)\"
+
+
+CLEANFILES =
+
+$(top_builddir)/libglusterfs/src/libglusterfs.la:
+ $(MAKE) -C $(top_builddir)/libglusterfs/src/ all