summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac102
1 files changed, 0 insertions, 102 deletions
diff --git a/configure.ac b/configure.ac
index e58bbee7a..21165316f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,15 +25,6 @@ AC_CONFIG_FILES([Makefile
libglusterfs/src/Makefile
libglusterfsclient/Makefile
libglusterfsclient/src/Makefile
- mod_glusterfs/Makefile
- mod_glusterfs/apache/Makefile
- mod_glusterfs/apache/1.3/Makefile
- mod_glusterfs/apache/1.3/src/Makefile
- mod_glusterfs/apache/2.2/Makefile
- mod_glusterfs/apache/2.2/src/Makefile
- mod_glusterfs/lighttpd/Makefile
- mod_glusterfs/lighttpd/1.4/Makefile
- mod_glusterfs/lighttpd/1.5/Makefile
glusterfsd/Makefile
glusterfsd/src/Makefile
booster/Makefile
@@ -203,94 +194,6 @@ fi
AC_SUBST(LIBGLUSTERFSCLIENT_SUBDIR)
# end LIBGLUSTERFSCLIENT section
-
-# MOD_GLUSTERFS section
-AC_ARG_ENABLE([mod_glusterfs],
- AC_HELP_STRING([--disable-mod_glusterfs],
- [Do not build glusterfs module for webserver. Currently supported module is for apache/1.3.x]))
-
-if test "x$enable_mod_glusterfs" != "xno"; then
- AC_ARG_WITH([apxs],
- AC_HELP_STRING([--with-apxs],
- [directory containing apxs binary]))
- if test "x$with_apxs" != "x"; then
- APXS_BIN=$with_apxs
- else
- APXS_BIN="$PATH"
- fi
- AC_CHECK_TOOL([APXS],[apxs], ["no"], [$APXS_BIN])
- if test "X$APXS" = "Xno"; then
- HAVE_APXS="no";
- else
- if test "x$with_apxs" != "x"; then
- APXS="$with_apxs/apxs";
- fi
- HAVE_APXS="yes";
- fi
-
- HAVE_LIBGLUSTERFSCLIENT="no";
- if test "x$BUILD_LIBGLUSTERFSCLIENT" = "xyes"; then
- HAVE_LIBGLUSTERFSCLIENT="yes";
- fi
-
- AC_ARG_WITH([apxspath],
- AC_HELP_STRING([--with-apxspath],
- [Path to apxs binary]))
-
- AC_ARG_WITH([apachepath],
- AC_HELP_STRING([--with-apachepath],
- [Path to apache binary]))
-fi
-
-if test "x$enable_mod_glusterfs" = "xyes" -a "x$HAVE_APXS" = "xno"; then
- echo "apxs is required to build mod_glusterfs. Use --with-apxs to specify path to apxs. If mod_glusterfs is not required, do not pass --enable-mod_glusterfs option to configure "
- exit 1
-fi
-
-if test "x$enable_mod_glusterfs" = "xyes" -a "x$HAVE_LIBGLUSTERFSCLIENT" = "xno"; then
- echo "libglusterfsclient is required to build mod_glusterfs. Do not specify --disable-libglusterfsclient to configure script. If mod_glusterfs is not required, do not pass --enable-mod_glusterfs option to configure "
- exit 1
-fi
-
-BUILD_MOD_GLUSTERFS=no
-MOD_GLUSTERFS_HTTPD_VERSION=""
-
-if test "x$enable_mod_glusterfs" != "xno" -a "x$HAVE_APXS" = "xyes" -a "x$HAVE_LIBGLUSTERFSCLIENT" = "xyes"; then
- BUILD_MOD_GLUSTERFS="yes";
- MOD_GLUSTERFS_SUBDIR="mod_glusterfs";
-fi
-
-if test "x$BUILD_MOD_GLUSTERFS" = "xyes"; then
- HTTPD_BIN_DIR=`$APXS -q SBINDIR`
- MOD_GLUSTERFS_HTTPD_VERSION=`$HTTPD_BIN_DIR/httpd -V | head -1 | awk "{print $3}" | sed 's/[[^0-9.]]//g' | sed 's/\(.*\..*\)\..*/\1/'`
-fi
-
-if test "x$with_apxspath" != "x"; then
- APXS_MANUAL=$with_apxspath
-fi
-
-if test "x$with_apachepath" != "x"; then
- HTTPD_MANUAL=$with_apachepath
-fi
-
-if test "x$enable_mod_glusterfs" != "xno" -a "x$with_apxspath" != "x" -a "x$with_apachepath" != "x"; then
- BUILD_MOD_GLUSTERFS="yes";
- MOD_GLUSTERFS_SUBDIR="mod_glusterfs";
- APACHE_MANUAL=yes
-fi
-
-if test "x$APACHE_MANUAL" = "xyes"; then
- HTTPD_BIN_DIR=`$APXS_MANUAL -q SBINDIR`
- MOD_GLUSTERFS_HTTPD_VERSION=`$HTTPD_MANUAL -V | head -1 | awk "{print $3}" | sed 's/[[^0-9.]]//g' | sed 's/\(.*\..*\)\..*/\1/'`
- APXS=$APXS_MANUAL
-fi
-
-AC_SUBST(MOD_GLUSTERFS_SUBDIR)
-AC_SUBST(APXS)
-AC_SUBST(MOD_GLUSTERFS_HTTPD_VERSION)
-# end MOD_GLUSTERFS section
-
-
# FUSE section
AC_ARG_ENABLE([fuse-client],
AC_HELP_STRING([--disable-fuse-client],
@@ -557,8 +460,6 @@ case $host_os in
GF_GLUSTERFS_LDFLAGS="-lexecinfo"
fi
GF_FUSE_LDADD="-liconv -lfuse"
- BUILD_MOD_GLUSTERFS=no
- MOD_GLUSTERFS_SUBDIR=""
BUILD_LIBGLUSTERFSCLIENT=no
LIBGLUSTERFSCLIENT_SUBDIR=""
GF_BOOSTER_SUBDIR=""
@@ -570,8 +471,6 @@ case $host_os in
GF_GLUSTERFS_CFLAGS="${ARGP_STANDALONE_CPPFLAGS} -D__DARWIN_64_BIT_INO_T -undefined suppress -flat_namespace"
GF_LDADD="${ARGP_STANDALONE_LDADD}"
GF_FUSE_LDADD="-liconv -lfuse_ino64"
- BUILD_MOD_GLUSTERFS=no
- MOD_GLUSTERFS_SUBDIR=""
BUILD_LIBGLUSTERFSCLIENT=no
LIBGLUSTERFSCLIENT_SUBDIR=""
GF_BOOSTER_SUBDIR=""
@@ -599,6 +498,5 @@ echo "Infiniband verbs : $BUILD_IBVERBS"
echo "epoll IO multiplex : $BUILD_EPOLL"
echo "Berkeley-DB : $BUILD_BDB"
echo "libglusterfsclient : $BUILD_LIBGLUSTERFSCLIENT"
-echo "mod_glusterfs : $BUILD_MOD_GLUSTERFS ($MOD_GLUSTERFS_HTTPD_VERSION)"
echo "argp-standalone : $BUILD_ARGP_STANDALONE"
echo