summaryrefslogtreecommitdiffstats
path: root/xlators/cluster/dht/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2009-11-25 21:26:24 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-11-26 03:04:26 -0800
commitfc87b19f0bd511ee294c058ea9066189ca06ce88 (patch)
treeda5fc99a43c28712a43858a0f744c131b46e9e4d /xlators/cluster/dht/src/Makefile.am
parent057c071403eb808b065e760d91101d519f86b65c (diff)
switch translator added
switch translator is a wrapper around distribute to work for a pattern based scheduling. Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 409 (implement a switch scheduler) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=409
Diffstat (limited to 'xlators/cluster/dht/src/Makefile.am')
-rw-r--r--xlators/cluster/dht/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/xlators/cluster/dht/src/Makefile.am b/xlators/cluster/dht/src/Makefile.am
index f87212699..70b89521e 100644
--- a/xlators/cluster/dht/src/Makefile.am
+++ b/xlators/cluster/dht/src/Makefile.am
@@ -1,5 +1,5 @@
-xlator_LTLIBRARIES = dht.la nufa.la
+xlator_LTLIBRARIES = dht.la nufa.la switch.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/cluster
@@ -9,6 +9,7 @@ dht_common_source = dht-layout.c dht-helper.c dht-linkfile.c \
dht_la_SOURCES = $(dht_common_source) dht.c
nufa_la_SOURCES = $(dht_common_source) nufa.c
+switch_la_SOURCES = $(dht_common_source) switch.c
dht_la_LDFLAGS = -module -avoidversion
dht_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
@@ -16,6 +17,9 @@ dht_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
nufa_la_LDFLAGS = -module -avoidversion
nufa_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+switch_la_LDFLAGS = -module -avoidversion
+switch_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
noinst_HEADERS = dht-common.h dht-common.c
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \