summaryrefslogtreecommitdiffstats
path: root/extras/init.d/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@zresearch.com>2009-03-01 05:35:18 -0800
committerAnand V. Avati <avati@amp.gluster.com>2009-03-03 11:44:21 +0530
commitda71d1359c1335997595935dbaa07c5747231861 (patch)
tree944744ee0a455b3684c20cac18849e5ff19af0f7 /extras/init.d/Makefile.am
parentb29a555c0be1c0db47c290d61f8c4dfe1e6fecbf (diff)
Added proper handling for the init scripts for (Debian, Ubuntu, SuSE, Redhat), SuSE init script also added.
* Init scripts added for Debian, Redhat, SuSE distribution, each are installed by checking each distribution specific. Tested on 1. Debian, Ubuntu. 2. Redhat, CentOS. 3. OpenSUSE. Signed-off-by: Anand V. Avati <avati@amp.gluster.com>
Diffstat (limited to 'extras/init.d/Makefile.am')
-rw-r--r--extras/init.d/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/extras/init.d/Makefile.am b/extras/init.d/Makefile.am
index 73e9745cd..66849af87 100644
--- a/extras/init.d/Makefile.am
+++ b/extras/init.d/Makefile.am
@@ -1,12 +1,15 @@
-EXTRA_DIST = glusterfsd glusterfs-server glusterfs-server.plist
+EXTRA_DIST = glusterfsd-Debian glusterfsd-Redhat glusterfsd-SuSE glusterfs-server.plist
CLEANFILES =
-initdir = $(sysconfdir)/init.d
-init_DATA = glusterfsd
+initdir = /etc/init.d
-install-data-local:
+$(GF_DISTRIBUTION):
+ $(mkdir_p) $(DESTDIR)$(initdir)
+ cp glusterfsd-$(GF_DISTRIBUTION) $(DESTDIR)$(initdir)/glusterfsd
+
+install-data-local: $(GF_DISTRIBUTION)
if GF_DARWIN_HOST_OS
cp glusterfs-server.plist /Library/LaunchDaemons/com.zresearch.glusterfs.plist
endif