summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuis Pabon <lpabon@redhat.com>2014-03-16 23:07:19 -0400
committerAnand Avati <avati@redhat.com>2014-03-17 11:12:08 -0700
commit6224e878cdf780360b49760c4b0c20584bbc0b6f (patch)
tree5761caff2cfd23e8ae5f2f44215a7fe2c371ae2c /configure.ac
parent9565ac3328dc91bd721a65b6d4e7957929e9ed59 (diff)
build: Remove cmockery2 from repo
While we wait for cmockery2 to be available from Fedora, we can remove cmockery2 from the repo. BUG: 1077011 Change-Id: I75d462c607cd376a5d838ea83f4d12eb59757e73 Signed-off-by: Luis Pabon <lpabon@redhat.com> Reviewed-on: http://review.gluster.org/7281 Reviewed-by: Justin Clift <justin@gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 3e34673f5..d3f5c1b18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -636,18 +636,6 @@ AC_SUBST(HAVE_LINKAT)
dnl check for Monotonic clock
AC_CHECK_FUNC([clock_gettime], [has_monotonic_clock=yes], AC_CHECK_LIB([rt], [clock_gettime], , AC_MSG_WARN([System doesn't have monotonic clock using contrib])))
-dnl Add cmockery2 for unit testing
-AC_CONFIG_SUBDIRS([cmockery2])
-UNITTEST_CFLAGS='-g -Wall -DUNIT_TESTING=1 -DDEBUG -Werror -O0 --coverage'
-UNITTEST_CPPFLAGS='-I$(top_srcdir)/cmockery2/src'
-UNITTEST_LDADD='$(top_builddir)/cmockery2/libcmockery.la'
-UNITTEST_LDFLAGS=-lgcov
-CFLAGS="$CFLAGS ${UNITTEST_CPPFLAGS}"
-AC_SUBST(UNITTEST_CFLAGS)
-AC_SUBST(UNITTEST_CPPFLAGS)
-AC_SUBST(UNITTEST_LDADD)
-AC_SUBST(UNITTEST_LDFLAGS)
-
dnl Check for argp
AC_CHECK_HEADER([argp.h], AC_DEFINE(HAVE_ARGP, 1, [have argp]))
AC_CONFIG_SUBDIRS(argp-standalone)