summaryrefslogtreecommitdiffstats
path: root/api/examples/Makefile.am
diff options
context:
space:
mode:
authorJustin Clift <justin@gluster.org>2014-03-21 13:18:29 +0000
committerVijay Bellur <vbellur@redhat.com>2014-03-24 10:31:55 -0700
commit446547559952e3b8af943f87c7475b80dd090153 (patch)
treeb9a7541a39fae83df919bcebd954611fd5d66649 /api/examples/Makefile.am
parent853a90f9d7399e4afdb685946a809e9dd30a1b98 (diff)
features/glupy: Rename Glupy python module to avoid namespace conflictrelease-3.5
* Rename gluster.py to glupy.py to avoid namespace conflict (#1018619) * Move the main Glupy files into glusterfs-extra-xlators rpm * Move the Glupy Translator examples into glusterfs-devel rpm Backport of: http://review.gluster.org/#/c/6979/ Change-Id: Ie9b71b56502f8e98c527ade381c918446bc7f022 BUG: 1018619 Signed-off-by: Justin Clift <justin@gluster.org> Reviewed-on: http://review.gluster.org/7316 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Diffstat (limited to 'api/examples/Makefile.am')
-rw-r--r--api/examples/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/api/examples/Makefile.am b/api/examples/Makefile.am
index 05f40ff53..f1a8d12b2 100644
--- a/api/examples/Makefile.am
+++ b/api/examples/Makefile.am
@@ -1,6 +1,10 @@
+# The bits needed for glfsxmp
EXTRA_PROGRAMS = glfsxmp
glfsxmp_SOURCES = glfsxmp.c
glfsxmp_CFLAGS = $(GLFS_CFLAGS) -Wall
glfsxmp_LDADD = $(GLFS_LIBS) -lrt
-EXTRA_DIST = gfapi.py
+# Install __init__.py (a generated file), and gfapi.py into
+# the Python site-packages area
+pygfapidir = $(pythondir)/gluster
+pygfapi_PYTHON = __init__.py gfapi.py