summaryrefslogtreecommitdiffstats
path: root/api/examples/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2013-09-30 09:05:14 +0200
committerVijay Bellur <vbellur@redhat.com>2013-12-24 04:12:23 -0800
commitb2ee85b3e452678c330c25bf32c522090bb320fc (patch)
treeedcccb745bc4b10127eb29e1e9395a2c3cfac651 /api/examples/Makefile.am
parent828a6eea202e9195f323a7c4b4656c73ecb34256 (diff)
gfapi.py: support dynamic loading of versioned librariesv3.4.2qa5
Currently gfapi.py only loads libraries by filename ending in ".so". On an installed system without development packages, the <lib>.so filenames are not available. ctypes.util.find_library() can be used to detect the files dynamically. In addition to this, also fixing some minor indention errors and package the library into the Python site-packages path. Python applications and libraries can now access libgfapi through 'from glusterfs import gfapi'. Change and review in the master branch: > Change-Id: I71e38dabd3ade5dcf24813bf2fc25cda91b571c6 > Signed-off-by: Niels de Vos <ndevos@redhat.com> > Reviewed-on: http://review.gluster.org/5835 > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> BUG: 1005146 Change-Id: Id7665fe5140111be7bf2038454fb775c70b15993 Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/6581 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'api/examples/Makefile.am')
-rw-r--r--api/examples/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/api/examples/Makefile.am b/api/examples/Makefile.am
index 6048bb1c8..cfb0d3dff 100644
--- a/api/examples/Makefile.am
+++ b/api/examples/Makefile.am
@@ -1,4 +1,6 @@
-noinst_PROGRAMS = glfsxmp
+EXTRA_PROGRAMS = glfsxmp
glfsxmp_SOURCES = glfsxmp.c
glfsxmp_CFLAGS = $(GLFS_CFLAGS) -Wall
-glfsxmp_LDADD = $(GLFS_LIBS) \ No newline at end of file
+glfsxmp_LDADD = $(GLFS_LIBS)
+
+EXTRA_DIST = gfapi.py