summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLuis Pabon <lpabon@redhat.com>2013-11-13 16:01:40 -0500
committerLuis Pabon <lpabon@redhat.com>2013-11-14 15:14:35 -0800
commitf54e06b612a6fdf04827ae32503dac5a7da5eb4e (patch)
treec052ba337f0975725d9820d74f83f64080ac3d58 /setup.py
parent40553ff9586aedccbddfbc57ce9c65463aac95b7 (diff)
Update RPM spec file
Update the RPM file with the comments from submittal spec file to the Fedora Project. This update also differntiates between the project name 'gluster-swift' and the Fedora distribution name 'glusterfs-openstack-swift'. This simple changes makes it less confusing when downloading the source on http://launchpad.net/gluster-swift . For more information on the Fedora Project submittal status please see: https://bugzilla.redhat.com/show_bug.cgi?id=1003089 This fix also creates a tar.gz source file so that Jenkins can archive it. This can be used for distributions other than RPM based systems. Change-Id: Ia9b85d53cf576a7754aaa018396adb70cb0f2855 Signed-off-by: Luis Pabon <lpabon@redhat.com> Reviewed-on: http://review.gluster.org/6261 Reviewed-by: Thiago Da Silva <thiago@redhat.com> Tested-by: Thiago Da Silva <thiago@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 4 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index abfd206..82b2a76 100644
--- a/setup.py
+++ b/setup.py
@@ -15,21 +15,17 @@
# limitations under the License.
from setuptools import setup, find_packages
-
-from gluster.swift import __canonical_version__ as version
-
-
-name = 'gluster_swift'
+from gluster.swift import _pkginfo
setup(
- name=name,
- version=version,
+ name=_pkginfo.name,
+ version=_pkginfo.full_version,
description='Gluster For Swift',
license='Apache License (2.0)',
author='Red Hat, Inc.',
author_email='gluster-users@gluster.org',
- url='https://forge.gluster.org/gluster-swift',
+ url='http://launchpad.net/gluster-swift',
packages=find_packages(exclude=['test', 'bin']),
test_suite='nose.collector',
classifiers=[