summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBala.FA <barumuga@redhat.com>2014-03-07 18:28:09 +0530
committerBala.FA <barumuga@redhat.com>2014-04-29 10:14:32 +0530
commit2977b2f34bdbb7284bcc6244e85a1fdb657447f2 (patch)
tree5e1e49207287b7ed8bddaefa5c6b58d07207ebc0 /tests/Makefile.am
parent4e1a40a920e6b2ee1be9f51b0f2a2f875ca790d3 (diff)
Initial commitv0.1.0
Change-Id: I45f91b2017ed59b057d21de52fd94c5c83fcf86f Signed-off-by: Bala.FA <barumuga@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..65843f4
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,50 @@
+#
+# Copyright 2014 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+#
+# Refer to the README and COPYING files for full details of the license
+#
+
+test_modules = \
+ $(NULL)
+
+dist_glusternagiosaddonstests_DATA = \
+ $(NULL)
+
+dist_glusternagiosaddonstests_PYTHON = \
+ $(test_modules) \
+ testrunner.py \
+ testValidation.py \
+ $(NULL)
+
+dist_glusternagiosaddonstests_SCRIPTS = \
+ run_tests.sh \
+ $(NULL)
+
+dist_noinst_DATA = \
+ run_tests_local.sh \
+ $(NULL)
+
+CLEANFILES = \
+ $(NULL)
+
+all-local: \
+ $(nodist_glusternagiosaddonstests_PYTHON)
+
+check-local:
+ @echo '*** Running tests. To skip this step place NOSE_EXCLUDE=.* ***'
+ @echo '*** into your environment. Do not submit untested code! ***'
+ $(top_srcdir)/tests/run_tests_local.sh $(test_modules)