summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bad6168..d0533c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([gluster-block.spec
Makefile
rpc/Makefile
+ rpc/rpcl/Makefile
cli/Makefile
daemon/Makefile
utils/Makefile
@@ -44,6 +45,11 @@ LT_INIT
# Checks for programs.
AC_PROG_CC
+AC_CHECK_PROG(RPCGEN, rpcgen, yes, no)
+if test "x$RPCGEN" = "xno"; then
+ AC_MSG_ERROR([rpcgen not found, needed for building])
+fi
+
# Checks for header files.
AC_CHECK_HEADERS([stdio.h stdlib.h string.h stdbool.h stddef.h \
unistd.h errno.h memory.h time.h \