summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e63b2c..7e5018b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,9 +40,12 @@ gitclean: clean distclean
ltmain.sh missing stamp-h1
rm -rf autom4te.cache ar-lib *.tar.gz m4
-dist-hook: gen-ChangeLog
+dist-hook: gen-ChangeLog gen-VERSION
-.PHONY: gen-ChangeLog
+.PHONY: gen-ChangeLog gen-VERSION
gen-ChangeLog:
(cd $(srcdir) && git diff && echo ===== git log ==== && git log) > $(distdir)/ChangeLog
+
+gen-VERSION:
+ (cd $(srcdir) && git describe --always --tags | cut -f2 -d'v' | cut -f1 -d'-') > $(distdir)/VERSION